SatNav Screen has gone black! - BMW M5 Forum and M6 Forums
E39 M5 and E52 Z8 Discussion 1998-2003 Advertiser's Forum

 
LinkBack Thread Tools Rate Thread Display Modes
post #1 of 9 Old 26th February 2011, 06:50 PM Thread Starter
hoop
Member, Sport: Off DSC: On (>50 posts)
 
hoop's Avatar
 
Join Date: Feb 2010
Location: Middle of Nowhere
Posts: 53
Thanks: 3
Thanked 2 Times in 2 Posts
SatNav Screen has gone black!

Hi there. Yesterday my sat nav`s screen has gone black during normal driving and never went back to normal! The back light seems to be on I can still use radio etc. It has happened before but it fix itself after a few hours. What I noticed is that when I was driving across pot holes etc it was flickering but only for a few secs. I have tried to disconnect baterry, sat nav and leave it for a bit but it won`t work! Has anyone got any ideas what happened?
hoop is offline  
Sponsored Links
Advertisement
 
post #2 of 9 Old 26th February 2011, 08:17 PM
mertonbmw
Member, Sport: Off DSC: On (>50 posts)
 
mertonbmw's Avatar
 
Join Date: Feb 2011
Location: Merton, WI
Posts: 57
Thanks: 1
Thanked 1 Time in 1 Post
My MKIII nav in my 2001 540i/6 did the same thing when it was cold (below 20F). It would work fine once the car would warm up (only after restarting). I did some research and what I found was the consensus said that the nav computer itself was going bad. I sold the car (not because of this problem) but had I kept it, I would have used the issue as a reason to upgrade to a MKIV nav computer.

Dig around on bimmerforums and you'll find some info.

Good luck!

current garage:

2008 Volkswagen Passat Wagon (for sale)
2007 Honda Odyssey Touring
1999 Audi A4 Avant
1992 BMW 325ic m-technicII
1991 BMW 318i 4dr slicktop (receiving s52 swap)
1988 BMW 325ic with factory hardtop

working on buying an e39M5, just sold an 2001 540i/6.
mertonbmw is offline  
post #3 of 9 Old 26th February 2011, 08:36 PM Thread Starter
hoop
Member, Sport: Off DSC: On (>50 posts)
 
hoop's Avatar
 
Join Date: Feb 2010
Location: Middle of Nowhere
Posts: 53
Thanks: 3
Thanked 2 Times in 2 Posts
Just went for evening spin and sat nav screen is working again! haven`t got a clue what is going on but still while driving it goes off on pot holes etc.
hoop is offline  
post #4 of 9 Old 26th February 2011, 10:13 PM
mertonbmw
Member, Sport: Off DSC: On (>50 posts)
 
mertonbmw's Avatar
 
Join Date: Feb 2011
Location: Merton, WI
Posts: 57
Thanks: 1
Thanked 1 Time in 1 Post
Sounds like a loose connection or something.

current garage:

2008 Volkswagen Passat Wagon (for sale)
2007 Honda Odyssey Touring
1999 Audi A4 Avant
1992 BMW 325ic m-technicII
1991 BMW 318i 4dr slicktop (receiving s52 swap)
1988 BMW 325ic with factory hardtop

working on buying an e39M5, just sold an 2001 540i/6.
mertonbmw is offline  
post #5 of 9 Old 27th February 2011, 12:07 PM
RichardP
M5 Guru (>2000 posts)
 
RichardP's Avatar
 
Join Date: Sep 2007
Location: North Yorkshire, UK
Posts: 3,066
Thanks: 111
Thanked 846 Times in 591 Posts
RichardP is offline  
post #6 of 9 Old 27th February 2011, 02:13 PM
Dearny
Junior Member, warming up (<31 posts)
 
Dearny's Avatar
 
Join Date: Nov 2009
Location: England
Posts: 22
Thanks: 2
Thanked 2 Times in 2 Posts
Another reason could be that your battery isn't receiving full charge, it has happened on my E39 (screen started up fine then used to flicker and go dim). Either your battery could be on the way out or possibly alternator, even a slipping fan belt can cause this, as it won't give the alternator what it wants. Get your battery tested to see if it's giving 12V or is dropping off.
Dearny is offline  
post #7 of 9 Old 27th February 2011, 05:57 PM
dan.
Member, P400 Sport, DSC On (>550)
 
dan.'s Avatar
 
Join Date: Mar 2010
Location: england uk
Posts: 585
Thanks: 29
Thanked 73 Times in 71 Posts
as richard mentioned the traffic master can interupt the screen and go black
i disconnected mine and sorted..never got to the bottom of it though.
dan. is offline  
post #8 of 9 Old 27th February 2011, 06:35 PM Thread Starter
hoop
Member, Sport: Off DSC: On (>50 posts)
 
hoop's Avatar
 
Join Date: Feb 2010
Location: Middle of Nowhere
Posts: 53
Thanks: 3
Thanked 2 Times in 2 Posts
Quote:
Originally Posted by RichardP View Post
Bypass the Traffic Master system if you still have it installed.
Yes, I think TM is still plugged in. I don`t really know how to bypass TM yet but will look for info. Is it on the board maybe? Or should I just disconnect all the wires from TM unit?

Last edited by hoop; 27th February 2011 at 06:37 PM.
hoop is offline  
post #9 of 9 Old 27th February 2011, 06:45 PM
dan.
Member, P400 Sport, DSC On (>550)
 
dan.'s Avatar
 
Join Date: Mar 2010
Location: england uk
Posts: 585
Thanks: 29
Thanked 73 Times in 71 Posts
unplug the blue connector on the tm,then near it is a male & female blue connector unplug that
with the remaining male blue plug put that into your tv module the plugs are all inline and connect the 2 units.
dan. is offline  
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the BMW M5 Forum and M6 Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes Rate This Thread
Linear Mode Linear Mode
Rate This Thread:



Similar Threads
Thread Thread Starter Forum Replies Last Post
Permanent brightness adjustment for satnav screen? m5knp E39 M5 and E52 Z8 Discussion 9 17th March 2013 11:31 PM
Is my navi dead? (black screen) deeno35 E39 M5 and E52 Z8 Discussion 4 13th July 2010 08:48 PM
Idrive screen goes black! Stewart W E63 BMW M6 Forum and BMW M6 Convertible | m6board.com 2 9th April 2007 10:53 PM
New fault [radio & satnav screen dying intermittently] M5DAL E39 M5 and E52 Z8 Discussion 2 10th February 2007 08:57 AM
Fitting X5 16:9 satnav screen in E39? minted_aye E39 M5 and E52 Z8 Discussion 1 14th August 2006 08:07 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome